Getting started

Contents
  • Introduction
  • Tools overview
  • Documentation
  • Setting up the UNIX evironment
  • Running Cadence Virtuoso
  • Quit the session
  • Licenses
  • Available licenses

Keywords:

Super protetta, non si puo' pubblicare/divulgare!

cdsdoc is no longer available! It has superseded by the Cadence Help. Type cdnshelp to acces the help system

The entire Cadence IC documentation is accessible through the cdnshelp executable located in

$IC_DIR/tools/cdnshelp/bin/cdnshelp

In order to be able to launch the executable modify your search path in your .cshrc file as follows: you can modify your search path

set path = ( $IC_DIR/tools/cdnshelp/bin $path)
source .cshrc
cdnshelp &

cdnshelp is the help document browser for Cadence. It opens .html files located in the install directory for each tool

La documentazione di Cadence IC e' in

/usr/cadence/IC_6.1.X/doc

cd ~/cadence
mkdir doc

Per Cadence IC usare:

La documentazione di **Cadence IC** e' in 

''<sub>/usr/cadence/IC_6.1.X/doc</sub>''


<code>
cd ~/cadence
mkdir doc

Per Cadence IC usare:

cd ~/cadence/doc
mkdir IC_6.1.5
cd IC
find /usr/cadence/IC_6.1.5/doc -name '*.pdf' -exec ln -s {} . \;

See also http://cadence.wikispaces.com/Documentation+index

Tutta la documentazione di Virtuoso platform e' accessibile dalla CIW come

CIW ⇒ Help ⇒ Virtuoso documentation

cd ~/cadence/doc mkdir IC_6.1.5 cd IC find /usr/cadence/IC_6.1.5/doc -name '*.pdf' -exec ln -s {} . \; </code>

See also http://cadence.wikispaces.com/Documentation+index

Tutta la documentazione di Virtuoso platform e' accessibile dalla CIW come

CIW ⇒ Help ⇒ Virtuoso documentation

Virtuoso Design Environment Executables

From the IC 6.1.4 release, all Virtuoso software executables have been integrated into one executable called virtuoso.

$IC_DIR/tools/dfII/bin/virtuoso

Cadence Virtuoso Schematic Editor L/XL

Schematic entry tool

Cadence Virtuoso Analog Design Environment L/XL/GXL

Graphical user interface to perform simulations

youtube video here

Cadence Virtuoso Layout Editor L/XL

Layout editor tool

Build your own Cadence IC documentation repository

La documentazione di Cadence IC e' in

/usr/cadence/IC_6.1.X/doc

cd ~/cadence
mkdir doc

Per Cadence IC usare:

cd ~/cadence/doc
mkdir IC_6.1.5
cd IC
find /usr/cadence/IC_6.1.5/doc -name '*.pdf' -exec ln -s {} . \;

See also here

Since the IC 6.1.4 release all Virtuoso software executables have been integrated into one executable called virtuoso

The executable is located in /usr/cadence/IC_6.1.X/tools/dfII/bin .

Tool File Loaction
Schematic Editor L comphelp.pdf /usr/cadence/IC_6.1.5/doc/comphelp
Analog Design Environment L anasimhelp.pdf /usr/cadence/IC_6.1.5/doc/anasimhelp
Analog Design Environment XL adexl.pdf /usr/cadence/IC_6.1.5/doc/adexl
Spectre spectreuser.pdf /usr/cadence/IC_6.1.5/doc/spectreuser
Layout Editor L vlhelp.pdf /usr/cadence/IC_6.1.5/doc/vlhelp
spectre -help  (just one - !)

Tutta la documentazione di Virtuoso platform e' accessibile dalla CIW come

CIW ⇒ Help ⇒ Virtuoso documentation


Last update: Luca Pacher - 02 Oct 2012

If needed, revisit the UNIX tutorial before proceeding.

Never run Cadence executables from your home directory! Cadence creates many extra files/directories that will clutter your home directory. Create indeed a main directory cadence in your home and another subdirectory tutorials in order to keep all the files that will be created:

Create a main ~/scratch directory if you did not yet

mkdir ~/scratch
cd  ~/scratch
mkdir tutorials
cd tutorials
mkdir data doc libs logs models src tmp 

Poi per runnare un cadence vanilla basta fare il source di

source /usr/local/config/cds_config/CdsIC_615.rc

You might retrive a MANPATH: Undefined variable error.

setenv MANPATH ""
source /usr/local/config/cds_config/CdsIC_615.rc
Execute Global CADENCE IC configuration version 6.1.5 HotFix 615
	Release 13 Jan 2012
which virtuoso
/usr/cadence/IC_6.1.5/tools/dfII/bin/virtuoso
xterm &

Tutorial:
http://www-classes.usc.edu/engr/ee-s/477p/IC6_Setup_Tutorial_v2.pdf

All Cadence IC executables have been integrated into a single executable called virtuoso. To run the Cadence IC framework move into the design directory and

cd ~/scratch/tutorials
virtuoso [options] &

at the command line. It's possible to launch virtuoso with some additional command line options. You can retrieve more information about them using:

virtuoso -h [-help]
virtuoso [-log ../logs/tutorial_1.log] &

Please, start the task into the background by adding the ampersand symbol & at the end of the command. In such way you will get the command prompt back right away. Otherwise you will no more be able to type commands in the xterm window.

The software may take some time to load. After the first Cadence splash screen has been shown the Command Interpreter Window (CIW) and a What's New window will appear.

Look at the information contained in the log window.

For more details and documentation about the CIW left click CIW ⇒ Help ⇒ Using the CIW.
The entire Virtuoso platform documentation can be accessed though CIW ⇒ Help ⇒ Virtuoso Documentation or entering at the comamnd line

$IC_DIR/tools/cdnshelp/bin/cdnshelp &

To quit the Cadence session left click on

CIW ⇒ File ⇒ Exit…

A confirmation dialog box should appear. Left click OK to quit Cadence or Cancel to resume.

A Save All window may appear. Left click OK to save design data.

You can view the list of Cadence licensed tools within Cadence itself from the Command Interpreter Window (CIW), simply look in

CIW ⇒ Options ⇒ License…

a tiered architecture (L/Xl/GXL), se viene checked-out a higher license automaticamente sono licenziati anche i tools inferiori

All Cadence software requires Cadence licenses!

Tutto e' sotto licenza! E c'e' un PC che fa solo da license server

You can use the Software Product License Management form to track token license activity.

CIW ⇒ Options ⇒ License …

You can check the state of the licence server or the number of available licences if you run into trouble opening a program.

The lmstat command can be used to track token license activity from the command line

lmstat [-help]

To view the number of available licences for each program,

lmstat -a

CDS_LIC_FILE ⇒ punta al server

LM_LIC_FILE



Last update: Luca Pacher - Apr 23, 2013

  • vlsi/workbook/analog/start.txt
  • Ultima modifica: 30/07/2014 11:16
  • da pacher